re = /-(.*)\((.*)\)/m
str = '-Quarter(18548748)
-Quarter(45786)
-Quarter(8378)
-Quarter(737863)
-OUTSOLE 01(87678)
-OUTSOLE 01(75786)
-OUTSOLE 01(434+67)
-OUTSOLE 01(786378+)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end