import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-(.*)\\((.*)\\)";
final String string = "-Quarter(18548748)\n"
+ "-Quarter(45786)\n"
+ "-Quarter(8378)\n"
+ "-Quarter(737863)\n"
+ "-OUTSOLE 01(87678)\n"
+ "-OUTSOLE 01(75786)\n"
+ "-OUTSOLE 01(434+67)\n"
+ "-OUTSOLE 01(786378+)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}