// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)-(.*)\((.*)\)").unwrap();
let string = "-Quarter(18548748)
-Quarter(45786)
-Quarter(8378)
-Quarter(737863)
-OUTSOLE 01(87678)
-OUTSOLE 01(75786)
-OUTSOLE 01(434+67)
-OUTSOLE 01(786378+)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}