using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-(.*)\((.*)\)";
string input = @"-Quarter(18548748)
-Quarter(45786)
-Quarter(8378)
-Quarter(737863)
-OUTSOLE 01(87678)
-OUTSOLE 01(75786)
-OUTSOLE 01(434+67)
-OUTSOLE 01(786378+)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}