using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<option(.*?)\s+(disabled)\s+(selected)\s+(hidden)>";
string substitution = @"<option \1 \2=""disabled"" \3=""disabled"" \4=""hidden"">";
string input = @"<option value="" disabled selected hidden>
<option value=""adfsa"" disabled selected hidden>
<option value=""111"" disabled selected hidden>
The output should be something like this:
<option value="" disabled=""disabled"" selected=""disabled"" hidden="">";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}