// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<option(.*?)\s+(disabled)\s+(selected)\s+(hidden)>").unwrap();
let string = "<option value=\"\" disabled selected hidden>
<option value=\"adfsa\" disabled selected hidden>
<option value=\"111\" disabled selected hidden>
The output should be something like this:
<option value=\"\" disabled=\"disabled\" selected=\"disabled\" hidden=\"\">";
let substitution = "<option \\1 \\2=\"disabled\" \\3=\"disabled\" \\4=\"hidden\">";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}