package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<option(.*?)\s+(disabled)\s+(selected)\s+(hidden)>`)
var str = `<option value="" disabled selected hidden>
<option value="adfsa" disabled selected hidden>
<option value="111" disabled selected hidden>
The output should be something like this:
<option value="" disabled="disabled" selected="disabled" hidden="">`
var substitution = "<option \1 \2="disabled" \3="disabled" \4="hidden">"
fmt.Println(re.ReplaceAllString(str, substitution))
}