import Foundation
let pattern = #"<option(.*?)\s+(disabled)\s+(selected)\s+(hidden)>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<option value="" disabled selected hidden>
<option value="adfsa" disabled selected hidden>
<option value="111" disabled selected hidden>
The output should be something like this:
<option value="" disabled="disabled" selected="disabled" hidden="">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<option \1 \2="disabled" \3="disabled" \4="hidden">"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)