#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.+[0-9]+.[0-9]+\.(png|gif|jpe?g)\.?(webp)?)$"
Local $sString = "/HOSTACC/public_html/fx/upd/y-icon-sprite-213x300.png" & @CRLF & _
"/HOSTACC/public_html/fx/upd/01/desx-yopy-small-150x150.png" & @CRLF & _
"/HOSTACC/public_html/fx/upd/old/maximumload-web-1920x1920.png" & @CRLF & _
"/HOSTACC/public_html/fx/upd/old/maximumload-web-1920x1920.png.webp" & @CRLF & _
"/HOSTACC/public_html/fx/upd/ex/new/old-storage-720x500.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")