use strict;
my $str = '/HOSTACC/public_html/fx/upd/y-icon-sprite-213x300.png
/HOSTACC/public_html/fx/upd/01/desx-yopy-small-150x150.png
/HOSTACC/public_html/fx/upd/old/maximumload-web-1920x1920.png
/HOSTACC/public_html/fx/upd/old/maximumload-web-1920x1920.png.webp
/HOSTACC/public_html/fx/upd/ex/new/old-storage-720x500.png';
my $regex = qr/^(.+[0-9]+.[0-9]+\.(png|gif|jpe?g)\.?(webp)?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}