import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+[0-9]+.[0-9]+\\.(png|gif|jpe?g)\\.?(webp)?)$";
final String string = "/HOSTACC/public_html/fx/upd/y-icon-sprite-213x300.png\n"
+ "/HOSTACC/public_html/fx/upd/01/desx-yopy-small-150x150.png\n"
+ "/HOSTACC/public_html/fx/upd/old/maximumload-web-1920x1920.png\n"
+ "/HOSTACC/public_html/fx/upd/old/maximumload-web-1920x1920.png.webp\n"
+ "/HOSTACC/public_html/fx/upd/ex/new/old-storage-720x500.png";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}