const regex = /^(.+[0-9]+.[0-9]+\.(png|gif|jpe?g)\.?(webp)?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+[0-9]+.[0-9]+\\.(png|gif|jpe?g)\\.?(webp)?)$', 'gm')
const str = `/HOSTACC/public_html/fx/upd/y-icon-sprite-213x300.png
/HOSTACC/public_html/fx/upd/01/desx-yopy-small-150x150.png
/HOSTACC/public_html/fx/upd/old/maximumload-web-1920x1920.png
/HOSTACC/public_html/fx/upd/old/maximumload-web-1920x1920.png.webp
/HOSTACC/public_html/fx/upd/ex/new/old-storage-720x500.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}