#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\w\s\()\w+\s\d+|(?<=\w\s\()\w+\s+\w+\s\d+"
Local $sString = "(ABC 123) Text string (DEF 456)" & @CRLF & _
"" & @CRLF & _
"(ABC 123) Text string (DEFG 123)" & @CRLF & _
"" & @CRLF & _
"(ABC 123) Text string (DEFG ABC)" & @CRLF & _
"" & @CRLF & _
"(ABC 123) Text string (123)" & @CRLF & _
"" & @CRLF & _
"(ABC 123) Text string (ABC DEF 123)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")