const regex = /(?<=\w\s\()\w+\s\d+|(?<=\w\s\()\w+\s+\w+\s\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\w\\s\\()\\w+\\s\\d+|(?<=\\w\\s\\()\\w+\\s+\\w+\\s\\d+', 'gm')
const str = `(ABC 123) Text string (DEF 456)
(ABC 123) Text string (DEFG 123)
(ABC 123) Text string (DEFG ABC)
(ABC 123) Text string (123)
(ABC 123) Text string (ABC DEF 123)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}