re = /(?<=\w\s\()\w+\s\d+|(?<=\w\s\()\w+\s+\w+\s\d+/m
str = '(ABC 123) Text string (DEF 456)
(ABC 123) Text string (DEFG 123)
(ABC 123) Text string (DEFG ABC)
(ABC 123) Text string (123)
(ABC 123) Text string (ABC DEF 123)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end