# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:EUR|USD|GBP|\G(?!^)\d+(?:\.\d+)?)\K( +)/ /gm;t' <<< "EUR 1.2
EUR 1.23
EUR 12
EUR 123
EUR 12 Mio.
EUR 12 345 Mio.
GBP 1 123 456 789 Mio.
USD 12 million
EUR 1.23 billion"