import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:EUR|USD|GBP|\\G(?!^)\\d+(?:\\.\\d+)?)\\K( +)";
final String string = "EUR 1.2\n"
+ "EUR 1.23\n"
+ "EUR 12\n"
+ "EUR 123\n"
+ "EUR 12 Mio.\n"
+ "EUR 12 345 Mio.\n"
+ "GBP 1 123 456 789 Mio.\n"
+ "USD 12 million\n"
+ "EUR 1.23 billion";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}