re = /(?:EUR|USD|GBP|\G(?!^)\d+(?:\.\d+)?)\K( +)/m
str = 'EUR 1.2
EUR 1.23
EUR 12
EUR 123
EUR 12 Mio.
EUR 12 345 Mio.
GBP 1 123 456 789 Mio.
USD 12 million
EUR 1.23 billion'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result