use strict;
my $str = 'EUR 1.2
EUR 1.23
EUR 12
EUR 123
EUR 12 Mio.
EUR 12 345 Mio.
GBP 1 123 456 789 Mio.
USD 12 million
EUR 1.23 billion';
my $regex = qr/(?:EUR|USD|GBP|\G(?!^)\d+(?:\.\d+)?)\K( +)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";