# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:EUR|USD|GBP|\G(?!^)\d+(?:\.\d+)?)\K( +)"
test_str = ("EUR 1.2\n"
"EUR 1.23\n"
"EUR 12\n"
"EUR 123\n"
"EUR 12 Mio.\n"
"EUR 12 345 Mio.\n"
"GBP 1 123 456 789 Mio.\n"
"USD 12 million\n"
"EUR 1.23 billion")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.