using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z]\d[a-zA-Z\d]\.?([a-zA-Z\d]{0,4})?$";
string input = @"# The regex should accept the modifier part of ICD10 codes, whether separated by a full stop or not
# Should be OK
V95.4
V97.33XA
V97.33XD
Y92.253
X96.2XXA
V95
V95.
G711
G71.1
G71.1234
# Should fail
V9
A23..
C12.34567
/12.544
G7111234
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}