const regex = /^[a-zA-Z]\d[a-zA-Z\d]\.?([a-zA-Z\d]{0,4})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z]\\d[a-zA-Z\\d]\\.?([a-zA-Z\\d]{0,4})?$', 'gm')
const str = `# The regex should accept the modifier part of ICD10 codes, whether separated by a full stop or not
# Should be OK
V95.4
V97.33XA
V97.33XD
Y92.253
X96.2XXA
V95
V95.
G711
G71.1
G71.1234
# Should fail
V9
A23..
C12.34567
/12.544
G7111234
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}