use strict;
my $str = '# The regex should accept the modifier part of ICD10 codes, whether separated by a full stop or not
# Should be OK
V95.4
V97.33XA
V97.33XD
Y92.253
X96.2XXA
V95
V95.
G711
G71.1
G71.1234
# Should fail
V9
A23..
C12.34567
/12.544
G7111234
';
my $regex = qr/^[a-zA-Z]\d[a-zA-Z\d]\.?([a-zA-Z\d]{0,4})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}