import Foundation
let pattern = #"^[a-zA-Z]\d[a-zA-Z\d]\.?([a-zA-Z\d]{0,4})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# The regex should accept the modifier part of ICD10 codes, whether separated by a full stop or not
# Should be OK
V95.4
V97.33XA
V97.33XD
Y92.253
X96.2XXA
V95
V95.
G711
G71.1
G71.1234
# Should fail
V9
A23..
C12.34567
/12.544
G7111234
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)