import re
regex = re.compile(r"^[a-zA-Z]\d[a-zA-Z\d]\.?([a-zA-Z\d]{0,4})?$", flags=re.MULTILINE)
test_str = ("# The regex should accept the modifier part of ICD10 codes, whether separated by a full stop or not\n"
"# Should be OK\n"
"V95.4\n"
"V97.33XA\n"
"V97.33XD\n"
"Y92.253\n"
"X96.2XXA\n"
"V95\n"
"V95.\n"
"G711\n"
"G71.1\n"
"G71.1234\n\n\n"
"# Should fail\n"
"V9\n"
"A23..\n"
"C12.34567\n"
"/12.544\n"
"G7111234\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")