const regex = new RegExp('\\[document\\s+(\\d+)]\\s+\\1(?!\\d)', 'gm')
const str = `[document 23] 23 and [document 34] 48 are white [document 24] 240 text`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);