use strict;
my $str = '[document 23] 23 and [document 34] 48 are white [document 24] 240 text';
my $regex = qr/\[document\s+(\d+)]\s+\1(?!\d)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";