re = /\[document\s+(\d+)]\s+\1(?!\d)/m
str = '[document 23] 23 and [document 34] 48 are white [document 24] 240 text'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result