import Foundation
let pattern = #"\[document\s+(\d+)]\s+\1(?!\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[document 23] 23 and [document 34] 48 are white [document 24] 240 text"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)