import re
regex = re.compile(r"\[document\s+(\d+)]\s+\1(?!\d)", flags=re.MULTILINE)
test_str = "[document 23] 23 and [document 34] 48 are white [document 24] 240 text"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)