#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:v)?[0-9]+\.[0-9]+\.[0-9]+(?:\-*(beta|alpha){0,1}\.[0-9]+)?$"
Local $sString = "1.2.3" & @CRLF & _
"1.2.3-" & @CRLF & _
"1.2.3-alpha" & @CRLF & _
"1.2.3-beta" & @CRLF & _
"1.2.3-alpha." & @CRLF & _
"1.2.3-beta." & @CRLF & _
"1.2.3-alpha.12345" & @CRLF & _
"1.2.3-beta.1" & @CRLF & _
"v1.2.3" & @CRLF & _
"v1.2.3-alpha.1" & @CRLF & _
"v1.2.3-beta.1" & @CRLF & _
"v11111111111.22222222222.3333333333"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")