$re = '/^(?:v)?[0-9]+\.[0-9]+\.[0-9]+(?:\-*(beta|alpha){0,1}\.[0-9]+)?$/m';
$str = '1.2.3
1.2.3-
1.2.3-alpha
1.2.3-beta
1.2.3-alpha.
1.2.3-beta.
1.2.3-alpha.12345
1.2.3-beta.1
v1.2.3
v1.2.3-alpha.1
v1.2.3-beta.1
v11111111111.22222222222.3333333333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);