package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:v)?[0-9]+\.[0-9]+\.[0-9]+(?:\-*(beta|alpha){0,1}\.[0-9]+)?$`)
var str = `1.2.3
1.2.3-
1.2.3-alpha
1.2.3-beta
1.2.3-alpha.
1.2.3-beta.
1.2.3-alpha.12345
1.2.3-beta.1
v1.2.3
v1.2.3-alpha.1
v1.2.3-beta.1
v11111111111.22222222222.3333333333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}