using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:v)?[0-9]+\.[0-9]+\.[0-9]+(?:\-*(beta|alpha){0,1}\.[0-9]+)?$";
string input = @"1.2.3
1.2.3-
1.2.3-alpha
1.2.3-beta
1.2.3-alpha.
1.2.3-beta.
1.2.3-alpha.12345
1.2.3-beta.1
v1.2.3
v1.2.3-alpha.1
v1.2.3-beta.1
v11111111111.22222222222.3333333333";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}