import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:v)?[0-9]+\\.[0-9]+\\.[0-9]+(?:\\-*(beta|alpha){0,1}\\.[0-9]+)?$";
final String string = "1.2.3\n"
+ "1.2.3-\n"
+ "1.2.3-alpha\n"
+ "1.2.3-beta\n"
+ "1.2.3-alpha.\n"
+ "1.2.3-beta.\n"
+ "1.2.3-alpha.12345\n"
+ "1.2.3-beta.1\n"
+ "v1.2.3\n"
+ "v1.2.3-alpha.1\n"
+ "v1.2.3-beta.1\n"
+ "v11111111111.22222222222.3333333333";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}