#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9a-fA-F]{8}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{12}$"
Local $sString = "ccc7c43c-8f4f-4963-a8f5-b2a7dfc2711a" & @CRLF & _
"018b587c851a7c9488eaf59f5c6dc701" & @CRLF & _
"6edf08d2-7102-11ee-b962-0242ac120002" & @CRLF & _
"6edf08d2-7102-11ee-b9623-0242ac12002" & @CRLF & _
"018b587c-851a-7c94-88ea-f59f5c6dc701" & @CRLF & _
"018b587c-851a-7c94-88ea-f59f5c6dcx01" & @CRLF & _
"218b5876-851a-7c94-uuea-f59f5c6dc701" & @CRLF & _
"" & @CRLF & _
"// You can show origina post on albertcolom.com/blog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")