const regex = /^[0-9a-fA-F]{8}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{12}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9a-fA-F]{8}\\-[0-9a-fA-F]{4}\\-[0-9a-fA-F]{4}\\-[0-9a-fA-F]{4}\\-[0-9a-fA-F]{12}$', 'gm')
const str = `ccc7c43c-8f4f-4963-a8f5-b2a7dfc2711a
018b587c851a7c9488eaf59f5c6dc701
6edf08d2-7102-11ee-b962-0242ac120002
6edf08d2-7102-11ee-b9623-0242ac12002
018b587c-851a-7c94-88ea-f59f5c6dc701
018b587c-851a-7c94-88ea-f59f5c6dcx01
218b5876-851a-7c94-uuea-f59f5c6dc701
// You can show origina post on albertcolom.com/blog`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}