use strict;
my $str = 'ccc7c43c-8f4f-4963-a8f5-b2a7dfc2711a
018b587c851a7c9488eaf59f5c6dc701
6edf08d2-7102-11ee-b962-0242ac120002
6edf08d2-7102-11ee-b9623-0242ac12002
018b587c-851a-7c94-88ea-f59f5c6dc701
018b587c-851a-7c94-88ea-f59f5c6dcx01
218b5876-851a-7c94-uuea-f59f5c6dc701
// You can show origina post on albertcolom.com/blog';
my $regex = qr/^[0-9a-fA-F]{8}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{12}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}