re = /^[0-9a-fA-F]{8}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{12}$/m
str = 'ccc7c43c-8f4f-4963-a8f5-b2a7dfc2711a
018b587c851a7c9488eaf59f5c6dc701
6edf08d2-7102-11ee-b962-0242ac120002
6edf08d2-7102-11ee-b9623-0242ac12002
018b587c-851a-7c94-88ea-f59f5c6dc701
018b587c-851a-7c94-88ea-f59f5c6dcx01
218b5876-851a-7c94-uuea-f59f5c6dc701
// You can show origina post on albertcolom.com/blog'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end