import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9a-fA-F]{8}\\-[0-9a-fA-F]{4}\\-[0-9a-fA-F]{4}\\-[0-9a-fA-F]{4}\\-[0-9a-fA-F]{12}$";
final String string = "ccc7c43c-8f4f-4963-a8f5-b2a7dfc2711a\n"
+ "018b587c851a7c9488eaf59f5c6dc701\n"
+ "6edf08d2-7102-11ee-b962-0242ac120002\n"
+ "6edf08d2-7102-11ee-b9623-0242ac12002\n"
+ "018b587c-851a-7c94-88ea-f59f5c6dc701\n"
+ "018b587c-851a-7c94-88ea-f59f5c6dcx01\n"
+ "218b5876-851a-7c94-uuea-f59f5c6dc701\n\n"
+ "// You can show origina post on albertcolom.com/blog";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}