#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(|www\.)(admin\.limmex\.de\/alarm|admin\.limmex\.de\/status|limmex\.com)(|\/[0-9]*)$"
Local $sString = "stage.shop.limmex.com" & @CRLF & _
"stage.shop.limmex.de" & @CRLF & _
"admin.limmex.de" & @CRLF & _
"admin.limmex.de/alarm/436761952161800" & @CRLF & _
"admin.limmex.de/alarm/4367619270344" & @CRLF & _
"admin.limmex.de/alarm/43676192703445" & @CRLF & _
"admin.limmex.de/alarm/353532064882314" & @CRLF & _
"admin.limmex.de/alarm/356051080526968" & @CRLF & _
"admin.limmex.de/status" & @CRLF & _
"www.limmex.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")