using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(|www\.)(admin\.limmex\.de\/alarm|admin\.limmex\.de\/status|limmex\.com)(|\/[0-9]*)$";
string input = @"stage.shop.limmex.com
stage.shop.limmex.de
admin.limmex.de
admin.limmex.de/alarm/436761952161800
admin.limmex.de/alarm/4367619270344
admin.limmex.de/alarm/43676192703445
admin.limmex.de/alarm/353532064882314
admin.limmex.de/alarm/356051080526968
admin.limmex.de/status
www.limmex.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}