$re = '/^(|www\.)(admin\.limmex\.de\/alarm|admin\.limmex\.de\/status|limmex\.com)(|\/[0-9]*)$/m';
$str = 'stage.shop.limmex.com
stage.shop.limmex.de
admin.limmex.de
admin.limmex.de/alarm/436761952161800
admin.limmex.de/alarm/4367619270344
admin.limmex.de/alarm/43676192703445
admin.limmex.de/alarm/353532064882314
admin.limmex.de/alarm/356051080526968
admin.limmex.de/status
www.limmex.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);