use strict;
my $str = 'stage.shop.limmex.com
stage.shop.limmex.de
admin.limmex.de
admin.limmex.de/alarm/436761952161800
admin.limmex.de/alarm/4367619270344
admin.limmex.de/alarm/43676192703445
admin.limmex.de/alarm/353532064882314
admin.limmex.de/alarm/356051080526968
admin.limmex.de/status
www.limmex.com';
my $regex = qr/^(|www\.)(admin\.limmex\.de\/alarm|admin\.limmex\.de\/status|limmex\.com)(|\/[0-9]*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}