const regex = /^(|www\.)(admin\.limmex\.de\/alarm|admin\.limmex\.de\/status|limmex\.com)(|\/[0-9]*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(|www\\.)(admin\\.limmex\\.de\\\/alarm|admin\\.limmex\\.de\\\/status|limmex\\.com)(|\\\/[0-9]*)$', 'gm')
const str = `stage.shop.limmex.com
stage.shop.limmex.de
admin.limmex.de
admin.limmex.de/alarm/436761952161800
admin.limmex.de/alarm/4367619270344
admin.limmex.de/alarm/43676192703445
admin.limmex.de/alarm/353532064882314
admin.limmex.de/alarm/356051080526968
admin.limmex.de/status
www.limmex.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}