# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/>\s+</></g;t' <<< "<div>
<p>Some paragraph here</p>
<div data=\"some data > < here\">
<p>some subparagraph here</p>
</div>
</div>"