#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ">\s+<"
Local $sString = "<div> " & @CRLF & _
" <p>Some paragraph here</p>" & @CRLF & _
" <div data="some data > < here"> " & @CRLF & _
" <p>some subparagraph here</p>" & @CRLF & _
" </div>" & @CRLF & _
"</div>"
Local $sSubst = "><"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)