import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">\\s+<";
final String string = "<div> \n"
+ " <p>Some paragraph here</p>\n"
+ " <div data=\"some data > < here\"> \n"
+ " <p>some subparagraph here</p>\n"
+ " </div>\n"
+ "</div>";
final String subst = "><";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}