use strict;
my $str = '<div>
<p>Some paragraph here</p>
<div data="some data > < here">
<p>some subparagraph here</p>
</div>
</div>';
my $regex = qr/>\s+</p;
my $subst = '><';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";