re = />\s+</
str = '<div>
<p>Some paragraph here</p>
<div data="some data > < here">
<p>some subparagraph here</p>
</div>
</div>'
subst = '><'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result